Hey!
I have to say again: Great Work!
But would it be possible to create a fluent interface for the vector things??
Because coding would be much easier then:
Code:
Old way:
Vector direction = new Vector(activeCCharacter.Position);
direction.vec_sub(EngVar.target);
direction.vec_normalize(5);

New Way:
Vector direction = new Vector(activeCCharacter.Position).vec_sub(EngVar.target).vec_normalize(5);



Sure it's not to hard to implement this. Afak the only thing to change is the return type of those vector functions....

Another thing, but i think it's too late for that:
We have object orientation so we can't simply call the function create of a BMAP with an ENTITY. My thought is:
Why to use those prefixes??

This would be much nicer:
ENTITY myEnt = ENTITY.create("pla",pla,pla);
Or even better:
ENTITY myEnt = new ENTITY("pla",pla,pla);

Would be cool to see this.

Greetz Felix


Visit my site: www.masterq32.de